Overview:
When completing a Call Objective, the user cannot see any progression happening on the related Account Tactics or Account Plan.
Root Cause:
The Progression Type of the Account Tactic is set to Manual_vod.
Solution:
Change the value on the picklist Progress_Type_vod__c to Call_Objective_vod.
With this option selected, the calculations occur whenever a Call Objective is completed.
Related Documentation:
CRM Help Documentation: Account Tactic