Overview:
When refreshing in Approved Email Administration or CLM Administration page in CRM Online, and error occurs: Foreign key external ID: xxxxx::xx not found for field VExternal_Id_vod__c in entity Product_vod__c.
Root Cause:
The product with the specified value in field VExternal_Id_vod__c cannot be found in CRM.
Solution:
In CRM, set the Product Veeva External ID as xxxxx or xxxxx::xx accordingly.
Product External IDs can be setup in two ways:
Scenario 1: Country is used.
- In Vault, External IDs need to be setup for Product and Country (i.e. Cholecap External ID = 1001 and France External ID = FR)
- In CRM, the Product Veeva External ID needs to be: Cholecap Veeva External ID = 1001::FR
Scenario 2: Country is not used.
- In Vault, External IDs need to be setup for Product (i.e. Cholecap External ID = 1001)
- In CRM, the Product Veeva External ID needs to be Cholecap Veeva External ID = 1001
Related Documentation:
CRM Help Documentation: Uploading Content via CLM Vault Integration