Overview:
Bookmarks on My Schedule are not returning to the last bookmark used after granting Edit permission to the Last_List_Scheduler_Bookmark_List_vod field on the Preferences_vod object.
Root Cause:
The Bookmark should reset to None in the following cases:
- Field Level Security (FLS) Change
- Veeva Setting change
- Multichannel Cycle Plan (MCCP) change
- No Preference record downloaded to the Offline device
Solution:
Verify if a Preference_vod record is downloaded to the offline device by following these steps:
- Navigate to the user's iRep --> Options --> Database.
- Scroll to the Preferences_vod__c object.
- Verify the record count.
Additionally, ensure if the user's Preference record Owner field is set to the affected user.
By setting the Owner field to the user, this allows the record to download to the Offline device due to the Out-of-the-box WHERE Clause for the Preferences_vod object:
- Where OwnerId = @@VOD_SF_USER_ID@@
Related Documentation:
CRM Help Documentation: Setting Bookmarks in Classic Cycle Plans