Overview:
Welcome emails are not being generated when creating users in bulk.
Root Cause:
The column vault_membership is not included in the CSV used to create the users.
Solution:
In some instances, the vault_membership column is not required and creates users with no errors. For welcome emails to be sent to the created users, the vault_membership column along with the Vault ID of the vault in which they are being created must be included.
Note: Adding the vault_membership column may make the app_licensing column required as well.
Related Documentation:
- Vault API Documentation: Updating Vault Membership in API
- Vault API Documentation: Creating Multiple Users in API
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.