Overview:
When navigating to an Account in Mobile CRM, there is a 4 to 10 second delay before the screen changes to the Call Report page.
Root Cause:
When recording a Call, CRM performs a search on any related objects, including the Approved_Document_vod object. If a user has synced a high number of Approved Documents to a device, the mechanism searches through all of those documents. This occurs even if none of the documents relate to the Call. This can cause a delay in loading the Call Report page.
Solution:
Limit the amount of Approved Documents that sync down to the device with a where clause on the Approved_Document_vod VMOC. This way a user syncs only those records that are needed.
Related Documentation:
N/A