Overview:
Duplicate Sample Limit Transactions are created when Calls error on sync which causes the Sample Limit to be incorrect.
Root Cause:
If a Call errors while syncing Online, Sample Limit Transactions can be created to prevent any data loss.
A common cause can be a validation rule that did not error Offline but is erroring Online, preventing the Call from being submitted.
Solution:
Correct all errors affecting the Call.
Delete the duplicate Sample Limit Transactions. Update the Sample Limit or make a manual adjustment to the Sample Limit.
Related Documentation:
CRM Knowledge Article: CRM Error Reference Guide