Overview:
ALLOWED_CALL_RECORD_TYPES limits Account Record Types to specific Call Record Types on the Call report. But, ALLOWED_CALL_RECORD_TYPES does not work in CRM iRep.
Root Cause:
There are duplicated ALLOWED_CALL_RECORD_TYPES Veeva Messages and one is empty.
It is possible that the SOQL request to find ALLOWED_CALL_RECORD_TYPES record returns an empty record first. Although the UI of Online and iRep use the same approach, only the first row is used.
A difference is the Online UI that additionally excludes any empty Veeva_Message settings.
Solution:
Deactivate or delete the empty ALLOWED_CALL_RECORD_TYPES Veeva Message.
Related Documentation:
CRM Help Documentation: Restricting Calls by Account Record Type