Overview:
CRM API com.veeva.clm.getApprovedDocument does not return the document id in iRep.
Root Cause:
In the query for an approved document, one criteria is the vault_id, it is set as: "https://xxxxx.veevavault.com/".
However, there is an additional trailing "/" character in the path.
Solution:
The trailing "/" character needs to be removed to find a match.
Related Documentation:
CRM Help Documentation: CRM API Reference