Overview:
After clicking on Consent Capture in a specific Account, the Approved Email Consent Type is not available.
Root Cause:
The value of Approved_Email_Opt_Type_vod__c is Never_vod on the Account, which overrides the possibility to capture Consent.
Solution:
Be sure, that Approved_Email_Opt_Type_vod__c is not set to Never_vod.
Related Documentation:
CRM Help Documentation: Consent Capture Overview