Overview:
When submitting a Survey through Approved Email, the Survey Administration tab displays the following error and the Survey Target record is not created. An error is reported: MALFORMED_ID: Survey Target: id value of incorrect type: surveyTargetId.
Root Cause:
Check that the integration user:
- does not have access to the Approved_Email_vod record type on the Question Response object
- does not have access to the appropriate Survey Target record types
or
- There is a trigger or validation rule that is preventing the Survey Target from getting created
Solution:
- Verify that the Survey integration user has access to the Approved_Email_vod record type on the Question Response object
- Verify that the Survey integration user has access to all necessary record types on the Survey Target object
- Verify that the Survey Target does not have a trigger or validation rule that is preventing the Survey Target record from getting created
Related Documentation:
CRM Help Documentation: Initial Configuration for Surveys