Overview:
The CRM Survey Target Territory Assignment is assigning Targets to the Creator only.
Root Cause:
When using the CRM Survey Target Territory Assignment, the system compares Account Territories with user Territories, only looking at users within the Territories selected in the Included User Territories drop-down list.
- If there is an overlapping Territory between a user and the Account, that user is selected as the owner of the Survey Target record.
- If there is more than one active user, the system selects the first active user retrieved as the owner of the Survey Target record.
- If a user in the matching Territory of the Account is still not assigned then there is a misconfiguration.
Solution:
Users in the territory must be set up for Survey use. The system attempts to assign a Survey Target record to a user that does not have Read permission to the Survey_Target_vod object. In this case, an entire individual batch (200 records) fails, so it is possible that all assignments fail.
Related Documentation:
CRM Help Documentation: Adding Assignment Rules to Surveys