Overview:
An end-user is receiving the error during sync: Required Fields Missing (lot_vod__c).
Root Cause:
The end-user creates a sample Call and selected one of the available lots (ex: lot #234) and keeps the Call in the saved_vod status. Before the user can submit the Call, the lot name changes (example: lot #234 to lot #456). When the user submits the Call, the Call fails to find the referenced lot name since it is modified.
Solution:
To correct this error the call2_sample_vod__c record should be modified Online. The field lot_vod__c should be updated to hold the correct name. After this is corrected, the end-user should sync one additional time.
Related Documentation:
CRM Help Documentation: N/A