Overview:
Updating CRM user record Veeva_USER_AFTER_UPDATE Fails with Error: Variable does not exist: IsActive.
Root Cause:
The reason why the reported error is occurring is that Salesforce also has a Class called User for the object on Salesforce's end. When the same name is used for a custom class, this creates a conflict and the standard fields from the original class are not recognized.
Solution:
Rename the custom Class from User to another name.
Related Documentation:
N/A