Overview:
A user is unable to see all of the documents available in their Vault.
Root Cause:
The user does not have the All Document Read Vault Action enabled.
Solution:
To enable this Vault Action:
- Navigate to: Admin --> Users & Groups --> Permission Sets --> [Permission Set] --> Application.
- Click the Edit button.
- Check the box.
- Save your changes.
The user is now able to view all of the documents available in the Vault.
NOTE: This only applies to Custom Permission Sets, as Standard Permission Sets are unable to be edited.
Related Documentation:
Vault Permission Set Documentation: About Permission Sets