Overview:
A CRM CoBrowse Presentation is missing from the Related List on the Call Report Page when using Detail Groups.
Root Cause:
When using a Detail Product that is a part of a Product Group assigned to a Detail Group Product, all configurations and permissions need to be set properly.
Solution:
The Mapping of Detail Groups from Vault needs to be created.
When using Detail Groups in a CRM org, they must be enabled in Vault. Detail Groups are disabled by default in Vault.
To enable Detail Groups in Vault:
- Populate the Detail Group values in Vault (Admin-->PromoMats Setup-->Picklists-> DetailGroup).
- Click Edit to add new Detail Groups. Do not delete the Common entry. This is required to map to the default Common group delivered in Veeva CRM.
To enable Detail Groups, add the picklist to the Email Template, Email Fragment, and Template Fragment document types.
- Navigate to the Document Properties. (Admin --> Content Setup).
- Select each of the above Document Types.
- Select Add, Existing Shared Property, and Detail Group. The user is able to select one value.
- Navigate to Property Layout (Admin --> Content Setup --> Property Layout) to order the Product Properties.
- Select Product Information from the list
- Click Edit and order so Detail Group is first and Product is second.
A Vault content administrator may not be familiar with the dependency between Detail Groups and Products. This is typically defined within CRM. In Vault, it is possible to setup dependent picklists where specific Products are grouped beneath specific Detail Groups to represent the CRM Detail Group + Product relationships. While not required, this will help guarantee valid Detail Group + Product attributes are selected.
To setup Property Dependencies:
- Navigate to Property Dependencies.
- Click Add a New Property Dependency.
- Select Controlled by Document Property.
- Select the Type.
- Repeat for Email Template, Email Fragment, Template Fragment.
- Select Detail Group from the Property picklist.
- Click OK.
- Select the desired Detail Group from the picklist in the Condition section if the property equals Detail Group.
- Select Picklist from the first picklist under the Dependency Rules section.
- Select Product from the next picklist.
- Choose the list of products to associate with the selected Detail Group.
Note: There can only be one Product and one Detail Group assigned to a single document. (Vault allows more than one Product to be assigned to a document, but this is not supported) CRM uses an external ID matching scheme to accurately assign the Product/Detail Group references in Veeva CRM, and the external IDs must be set up in advance in Vault and in CRM.
The end user must have access to the Detail Group, Product Group, and Detail Product Records and set up for the End User's My Setup.
Related Documentation:
CRM Help Documentation: Using Detail Groups and Detail Topics
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