Overview:
A Survey Target is created Offline in Veeva CRM iPad and synchronized to Online without any error. However, the Account_vod__c field in Survey Target disappears after synchronizing.
Root Cause:
The end-user does not have Edit Field Level Security (FLS) to the Entity Reference ID field on the Survey Target object.
Solution:
Provide the end-user with Edit FLS to the Entity Reference ID field on the Survey Target object.
Follow these steps to grant FLS:
- From the Administration Setup menu, navigate to: Manager Users --> Profiles.
- Find and enter the profile name to grant access to.
- Go to Field-Level Security --> Custom Field-Level Security --> Object Survey Target.
- Edit the FLS by adding both Read and Edit access.
Related Documentation:
CRM Help Documentation: Configuring Surveys