Overview:
When dragging and dropping an Account to the CRM for iPad My Schedule page at a specific time to schedule a call, the call is instead moved to all day.
Root Cause:
The User's Profile is either missing Read and Edit Field Level Security (FLS) to the Call_Datetime_vod field on the Call object (Call2_vod), or the Call_Datetime_vod field is missing from the Call page layout.
Solution:
Ensure that the user has Read and Edit FLS to the Call_Datetime_vod field, and that the field is added to the Call page layout.
Related Documentation:
CRM Help Documentation: Capturing the Call Date Only