Overview:
When the user performs push to CRM job, it returns the following error:
Cannot Push territories or assignments to demo.apac due to the territory hierarchy having more than one CRM Org specified.
Root Cause:
All territories in the pushing Territory branch need to have the same Veeva CRM Org value. if there is no Veeva CRM Org value set in the Territory branch, it causes a validation error.
For Example:
in the diagram below, the territory SG West and on Child territory SGW1 have the Veeva CRM Org set. Other side branch territories SGW2 and SGW3 are not set in the Veeva CRM Org.
Solution:
- Add a Veeva CRM Org value to the corresponding side branch Territory.
- Run the Push to CRM job again.
Related Documentation:
N/A
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.