Overview:
The Territories field on the Account page is not updated in Brick-based Alignments, even though the Territory_vod field is already populated.
Root Cause:
One reason for this problem is that there is another rule preventing the Account to be assigned to a specified Territory although the Account matches the rule VT-RuleXXXX which is created by Brick-based Alignments.
Solution:
Account assignment rules are governed by the following:
- A Territory can have inherited Account assignment rules, meaning that the rules were created somewhere higher in the Territory hierarchy and consequently also impact the given Territory.
- A Territory can have locally defined Account assignment rules, meaning that the rule was created at the given Territory.
- If a Territory doesn't have any inherited or locally-defined Account assignment rules, then it only contains Accounts that were manually added.
- If an Account matches all inherited and locally-defined Account assignment rules for multiple Territories on the same branch of the hierarchy, then the Account is assigned to the lowest matching Territory.
- If an account matches a Territory's inherited account assignment rules but not all of the Territory's locally-defined rules, then the Account is not assigned to the Territory, but is evaluated for child Territories.
The user needs to decide whether or not to disable or modify the relevant rule which is preventing the Account from being assigned to the specified Territory.
Related Documentation:
Salesforce Help Documentation: Managing Account Assignment Rules