Overview:
When adding a Queue as an Event Team Member in CRM, the related records are not being shared with the Queue users.
Example:
The test Queue is added as an Event Team Member. However, the related record Expense Estimate EE-0000000011 is not being shared with the Queue users.
Root Cause:
The object (Example: Expense Estimate) is not added as a supported object for that Queue.
If adding a Queue as a team member, all objects included in the related list must be added to the list of supported objects for that queue to enable auto-sharing.
Solution:
Add all objects included in the related list to the list of supported objects for that Queue:
- Open the Queue.
- Click the Edit button.
- Add the object (example: Expense Estimate) to Selected Objects.
- Click the Save button.
Once this is done, the related records can be shared with the Queue users as expected.
Note: The Event Team Member sharing rules are only evaluated when adding an Event Team Member to an Event. If the Supported objects for a Queue are changed after this point (e.g. add Expense Estimate), the Event Team Member needs to be deleted and re-added to the Event to change the Expense Estimate object access.
Related Documentation:
CRM Help Documentation: Event Team Members
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.