Overview:
The Engage contents cannot be synced as an error is reported:
Vault API call failed. Vault transaction id: http-VLT-AP-NORTHEAST-1-PRODUCTION-34-431894-65 response status: FAILURE error type: INCORRECT_QUERY_SYNTAX cause: Cannot parse the search phrase [select title__v,cobrowse_content__v,language__v,name__v,product on the Engage Metadata Sync Administration Console tab.
Root Cause:
The Vault WHERE Clause is incorrect.
Solution:
A CRM System Admin can follow the steps below to resolve this issue:
- Go to Engage Metadata Sync Administration Console tab.
- Click the Edit button in the Vault Connection Management Section.
- Modify the value of the Vault WHERE Clause input box (in this case delete the value), then input the Password and click the Save button.
- Implement the Sync or Force Full Refresh.
Related Documentation:
Related Article: What Are the Supported WHERE Clauses for the CRM queryRecord CLM API call?