Overview:
When changing the Parent Directory of a Directory in CRM Online, an error occurs: Error: Invalid Directory. Directory level cannot be the same as the Parent Directory level.
Root Cause:
When a Directory is changed with the level that is the same level as its parent directory, the error occurs.
Solution:
One solution is to do the following:
- Release the relationship with its child Directory by removing the Parent Directory value of its child Directory.
- Once no child Directory exists, the Parent Directory value can be changed as expected.
- Set the Parent Directory value back to its child Directory that is being removed in step 1.
Related Documentation:
N/A
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.