Overview:
An Object is not included in search results in CRM Online.
Root Cause:
The object tab visibility for the affected user's assigned profile is set to Tab Hidden or the object's setting Allow Search is disabled.
Solution:
An object is not included in search results. Be sure to check the following:
- The object has a tab.
- Its tab visibility for the affected user's assigned profile is set to Default On or Default Off and not Tab Hidden.
- The object's setting Allow Search is enabled.
Related Documentation:
Salesforce Help Documentation: Object missing or search results different for each User