Overview:
When scheduling a CRM Call in My Schedule, an Error occurs:
Required Fields are missing.
Root Cause:
This error displays when the Field is set to required on the Call object.
It is not recommended that the field is marked as required on the object level. Set the field as required based on the Call page layout.
Solution:
Remove the required setting on the Field at the Object level.
Related Documentation:
CRM Help Documentation: N/A