Overview:
In Offline CRM, it is not possible to add Promotional Items to the Call Report even though the Product records are properly configured. The respective Products are assigned to the user using My Setup. Online, the Promotional Items are available for selection.
Root Cause:
The user profile has Read access but is missing Create and Edit access to the Call2_Sample_vod__c object.
Solution:
Grant at least Read, Create, and Edit access to the user profile to the Call2_Sample_vod__c object as described below:
- Open the User detail page.
- Click on the user profile link.
- Click Edit.
- Scroll down to the Custom Object Permissions section.
- Check (Enable) the appropriate boxes next to the Call Sample object.
- Clear the Veeva Cache.
- Perform a database refresh with the user on the Offline device.
Once the Create and Edit permission is granted, the Promotional items are available for selection Offline:
Related Documentation:
CRM Help Documentation: Configuring Call Sampling