Overview:
When Running a Territory Sales Analysis Report, a user receives an error: There is no data for the selected filters.
Root Cause:
The runtime options of the report must pull valid data from the Analytics file. Review the analytics file to confirm there is valid data, that match the runtime options, for Accounts the user has access to.
Other common causes include:
- The selected Segment does not have any Accounts
- The User is missing Field Level Security (FLS) to ID_vod__c field on the Account object
- A child analytic product is a company product and does not have a Product Group Map
Solution:
To find if the selected Segment has any Accounts for the User:
- Log in as the user.
- Go to My Accounts.
- Select the View.
- At least one Account from the Analytics File should display.
If the User is missing FLS to the ID_vod__c field on the Account object, do the following (to Provide Field Level Security to a User):
- Log into the Org as a System Administrator.
- Navigate to the User --> User Detail.
- Drill into the Profile.
- Go to the Field-Level Security section.
- Click [View] next to the Account.
- Click Edit.
- Check Read Access next to the ID_vod__c.
- Select Save.
- Clear the Veeva Cache.
To determine if the child analytic product has a Product Group Map:
- Go to the Analytics Product Group of the Parent Product.
- Look at all Analytics Product Groups for child products that are Company Products.
- If they are Company Products, they must have a related Product Group Map record.
Related Documentation:
CRM Help Documentation: Configuring Fixed Reports Pages