Overview:
When a user creates a new Call or Interaction, the Call page takes a long time to load. There are a large number of Attendees listed when it does load.
Root Cause:
The --paa Section Signal (Display all Attendees) is added to the Attendees section of the Call Report which displays all of the suggested Attendees for an Individual call.
Solution:
Remove the --paa section signal from the Attendees section of the Call Report layout and replace it with the --su (Search Accounts and Users) section signal. This allows the user to search for Accounts to be added instead of listing all of them by default.
Note: There are additional configuration options available to reduce the number of Attendees presented on the Call Report or easily locate an Attendee in a large list if removing the Attendees list, in its entirety which is not an option for use.
Adding Account Identifiers on the Call Report
Account and User identifiers are available in the Call Report to help users quickly find and select the correct Attendee when there is a large number of Attendees to select from. Call types that are affected include:
- Group Call to Business Account
- Person Account with the -- paa section signal
- Event Calls with Attendees
To configure Account Identifiers, use these steps:
- Add the zvod.Account_Account_Identifier_vod field in the Attendees section of the Call Report page layout.
- Ensure users have Field Level Security (FLS) Edit permission to the Account_Identifier_vod field on the Account_vod object and the User_Identifier_vod field on the User object.
In the Attendees section of the Call Report, the Account identifier information displays below the Attendee name. The usernames display below the Accounts. When users add Account and User Attendees to the Call, the Attendees are divided by type and then sorted alphabetically. This provides the user a visual queue when identifying different Attendee types.
Adding Attendee Target Filters
The Attendees section on the Call report can be configured to display targeted accounts as the default suggested attendees. This feature is useful for Calls made against Business Accounts that have a large number of associated Health Care Providers (HCPs).
To configure Attendee Target Filters, use these steps:
- Add the --atf (Attendee Target Filter) section signal in the section that contains the zvod_Attendees_vod field.
- Set the My_Target_vod field on the TSF_vod object to TRUE for the user's territory.
The user can still search for additional attendees and add them to the Call even if they are not defined as targets.
Related Documentation:
CRM Help Documentation: