Overview:
Veeva CRM Sync Error unexpected token: ')' due to OwnerId IN ().
Root Cause:
This error occurs when all the following conditions are true:
- VMOC WHERE clause contains the META-SOQL variable @@VOD_USERS_IN_MY_TERRITORY:OwnerId@@
- Sync User's Territory is Changed in Salesforce
- Veeva Cache is not cleared
- Sync User's Previous Territory no longer contains any users
- A User Syncs
Solution:
To avoid the error, do the following:
- Clear Veeva Cache after making user Territory changes.
Related Documentation:
CRM Help Documentation:
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