Overview:
When saving a change to a CRM Account record online, the page hangs or freezes, and the Account change does not save.
Root Cause:
There are Data Change Requests (DCR) fields missing on the page layout that are flagged as required on the DCR Field Types tab.
Solution:
Add the missing fields to the page layout, or mark the fields as not required.
Related Documentation:
CRM Help Documentation: Configuration of DCR Controlled Fields