Overview:
After performing a sync, the user receives the following error: Unknown response:var ERROR_ENTER_VALUE = 'Error: You must enter a value'. Additionally, the sync time does not get updated on the Home Page of the Offline device.
Root Cause:
Usually, the error message appears when there is a permission change Online that is synced to SFDC metadata. However, it is not synced down to Offline. At the time of the error, the user tries to sync an empty field which is mandatory Online.
Solution:
To solve the issue, do the following:
- Clear Veeva Cache.
- Perform a full database refresh on the user's device.
Preventive action:
After setting the Force_Full_Refresh_vod__c field to TRUE on the User Detail page, the error does not occur.
Related Documentation:
CRM Knowledge Article: What are the Most Common CRM Sync Errors?