Overview:
The same product appears multiple times in Suggestion Summary on the left of the Suggestions page.
Root Cause:
Suggestion Tag records were created incorrectly with a Product linked, but no Record Type was assigned. Suggestion Tags corresponding to Products should belong to the Product_vod Record Type.
Solution:
Invalid Suggestion Tag records will need to be deleted, and created with the correct Record Type assigned.
Related Documentation:
CRM Help Documentation: Suggestions