Overview:
When viewing a territory record in Veeva Align in the Vault View (Vault), several fields are missing from the page layout even though they are added to it. It is also not possible to create new or save existing Territories.
In Admin View (Admin), all fields are visible.
Root Cause:
The issue is caused because the CRM Account Access field is not found on the Territory page layout.
Solution:
Place the CRM Account Access field on the Territory page layout.
Related Documentation:
Align Help Documentation: Configuring Align