Overview:
Upon configuring specific Territory Specific Field (TSF) Page Layouts for specific TSF Record Types, the customized page layout does not change on the Account page based on the assigned TSF Record Type.
Root Cause:
The issue is related to the mismatching of both labels and names of the Account Record Type and TSF Record Type.
Solution:
- Be sure the value of the Record Type Label of the TSF Record Type matches exactly to the value of the Record Type Label of Account Record Type. This includes case sensitivity as well.
- Be sure that the value of the Record Type Name of the TSF Record Type matches exactly to the value of the Record Type Name of the Account Record Type. This includes case sensitivity as well.
- Clear the Veeva Cache in order for the changes to take effect Online.
Run a Database Refresh on the mobile device in order for the changes to take effect Offline.
Related Documentation:
CRM Help Documentation: