Overview:
Not all values of a custom Picklist display when the user translates picklist values in the Translation Workbench in CRM Online. How does that happen?
Root Cause:
Salesforce(SFDC) uses the Previous and Next buttons at the bottom of the translation screen for switching between the fields. SFDC also uses this to switch the values that these fields contain.
Solution:
The user needs to click the Next button to get the next block of picklist values to appear.
Related Documentation:
N/A