Overview:
Company Alerts that are defined in Alert_vod records can be pushed to iPhone CRM.
Sometimes, the defined Alert_vod records cannot be pushed to iPhone CRM even though the Mobile CRM Scheduled Push Notifications process runs successfully. In addition, no errors display in the Scheduled Push Notification History section of the Mobile CRM App Administration page.
Root Cause:
Not all Alert_vod records are pushed to the iPhone. The Mobile CRM Scheduled Push Notifications process only pushes notify Alert_vod records that meet certain criteria.
Solution:
Be sure the created Alert_vod records meeting the following criteria:
- Push_Notify_APNS_Status_vod = Queued_vod
- Activation_Date_vod <= Current Date/Time
- Expiration_Date_vod >= Current Date/Time
This allows the customer to control which alerts and how many alerts are pushed to the field user's iPhone so that the field users are not bombarded with many push notifications.
In addition to the above, be sure the VMobile Object Configuration (VMOC) for the Mobile_Device_vod object with iPhone Device type is activated.
Related Documentation:
CRM Help Documentation: Managing Push Notifications