Overview:
When attempting to download User Activity Logs, an error occurs:
Error generating Activity Log.
Root Cause:
When a user clicks on the Activity logs link, Veeva CRM runs a query in the background to check if the user has access to edit the user record for which the logs are being pulled. If the user does not have access to edit the user record, then the user cannot download the logs.
QUERY: SELECT toLabel (RecordId),HasEditAccess FROM UserRecordAccess WHERE UserId= '...' AND RecordId= '...'
Solution:
Provide the user, who is attempting to download the Activity Log, Edit access to the user's record.
Related Documentation:
N/A