Overview:
Why are the current or future Assignments of a Territory not end-dated when the related Territory is end-dated in Veeva Align?
Root Cause:
The security profile of the end-user who end-dates the Territory - has no Edit permission on the Status field of the following objects:
- Account Territory
- Roster Member Territory
- Footprint Territory
- Product Territory
- Geography Territory
This is also indicated by the error message(s) found in the error log(s) of the Assignment Update job(s) related to any of the mentioned object(s) respectively:
- account_territory__aln Failed to Update. Reason: OPERATION_NOT_ALLOWED: Cannot update field [status__v]
- roster_member_territory__aln Failed to Update. Reason: OPERATION_NOT_ALLOWED: Cannot update field [status__v]
- footprint_Territory__aln Failed to Update. Reason: OPERATION_NOT_ALLOWED: Cannot update field [status__v]
- product_territory__aln Failed to Update. Reason: OPERATION_NOT_ALLOWED: Cannot update field [status__v]
- geography_territory__aln Failed to Update. Reason: OPERATION_NOT_ALLOWED: Cannot update field [status__v]
Solution:
Provide Edit permission to the user's security profile on the Status field of the following Align objects:
- Account Territory
- Roster Member Territory
- Footprint Territory
- Product Territory
- Geography Territory
Related Documentation:
Align Help Documentation: N/A
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