Overview:
When opening the My Accounts tab, the following error occurs: Unable to access this feature. Your account does not have all the required permissions.
Root Cause:
The user does not have the appropriate object permissions to either of the following objects:
- Account
- Address_vod__c
- Preferences_vod__c
- Product_Metrics_vod__c
- TSF_vod__c
- View_vod__c
- Message_vod__c (Veeva Message)
Solution:
To prevent the error, do the following:
- Provide the end user at least Read and Edit permissions to the objects above and at least Read Object Level Permission to the Veeva Message Object.
- Clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: My Accounts