Overview:
When creating a new Account Data Change Request (DCR) from the New Account Wizard, an Address DCR record is missed. However, it works for an Online DCR.
Root Cause:
This user profile does not have visibility to the Mobile_ID_vod__c field on the Address_vod__c object.
Solution:
Grant Field Level Security (FLS) access to the Mobile_ID_vod__c field on the Address_vod__c object.
Users who create records Offline need FLS Edit access to the Mobile_ID field on the object to which they are creating the record.
Related Documentation:
CRM Help Documentation: Administrative Do's and Don'ts