Overview:
How to Identify if a Custom Validation Rule is causing an error message when syncing CRM Offline?
For example, a line in the Activity Logs displays a message: Error message: Please only check one field.
Root Cause:
A user can receive the error message when syncing for a variety of reasons. There are two common causes:
- An error caused by the misconfiguration of Veeva. There is a list of all error messages in the CRM Error Reference Guide and most errors have a Knowledge Base (KB) article with detailed steps to resolve the error.
- An error message from a custom Validation Rule.
Solution:
To identify the Validation Rule, search the Rule_Definition_vod__c object for a record with the Master_Message_vod__c matching the error message.
*** Callout Section ***
SELECT Active_vod__c,Error_Condition_Formula_vod__c,Id,Master_Message_vod__c,Name,Object_vod__c FROM Rule_Definition_vod__c
Related Documentation:
CRM Knowledge Article: CRM Error Reference Guide