Overview:
Some expenses fail to sync to Concur with the error below:
<Message>Customxx has an invalid value. Please check the API documentation to learn how to provide valid values.</Message>
The column with the above error is the name of product Product XXX.
<Customxx>Product?? XXX</Customxx>
The product name in the log file looks fine as UTF-8 encoding. However, if the user opens the log file as ISO 8859-1 encoding, the product name appears as Product XXX.
<Customxx>Product XXX</Customxx>
This special character causes the failure of relevant expense records during a Concur sync.
Root Cause:
The cause of the issue is that the space between the char t and X in the product name Product XXX is a no-break space (U+00A0), not a regular space (U+0020). The difference is not visible to the end-user.
Solution:
Change the no-break space to a regular space. This should fix the issue.
Related Documentation:
N/A