Overview:
Consent lines Opt-In or Opt-Out is applying to all lines, rather than to the specific consent line, that is Opted-In or Opted-Out.
Root Cause:
The Consent Lines have the Sub_Channel_vod Record Type, however, the field Sub Channel Key is not completed on the Consent Line records.
Solution:
Populate the Sub Channel Key field on the Consent Line.
Related Documentation:
CRM Help Documentation: Consent Capture Overview