Overview:
Why does the Sphere of Influence Render Properly Offline, but Online only shows the Previous and Next Buttons?
Root Cause:
If the Sphere of Influence is rendering properly on CRM Offline but not on CRM Online, it is most likely caused by an incorrect text in the Veeva Message ACCOUNT_RECORD_TYPE_ICON_MAP in the category Common.
The text of this Veeva Message should not have new lines between the variables.
Solution:
Remove all the new lines between the variables of the Veeva Message:
ACCOUNT_RECORD_TYPE_ICON_MAP
Example:
The following text in the Veeva Message ACCOUNT_RECORD_TYPE_ICON_MAP causes the Sphere of Influence to not render Online:
Government_Agency_vod:Institution_vod;
Professional_vod:Person Account;
Since the text should not include new lines, the Veeva Message text should be updated to:
Government_Agency_vod:Institution_vod;Professional_vod:Person Account;
Once the text of the Veeva Message is corrected, it is required to clear the Veeva Cache to render again the Sphere of influence.
Related Documentation:
CRM Help Documentation: Sphere of Influence
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