Overview:
Error: Insufficient Privileges - When viewing a child account from the related list on account page in Online CRM.
Root Cause:
The View button is replaced by Visualforce Page View Child Account2 [View_Child_Account2_vod]. However, the user does not have the access to that Visualforce Page.
Solution:
Grant the end-user access to the Visualforce Page.
- Navigate to Setup.
- Find Profiles in the quick search bar and go to Manage Users --> Profiles.
- Select the user's profile.
- Click the Edit button on the enabled Visualforce Page Access section.
- Add the View_Child_Account2_vod Visualforce Page.
Related Documentation:
CRM Online Help: Working with Child Accounts