Overview:
When accessing Survey Detail page in CRM Online, an error occurs: View mode in Surveys without survey data.
Root Cause:
One possible reason is that the end-user does not have the Field-Level Security (FLS) to the Question Order (Order_vod__c) field in the Survey_Question_vod__c object. Or, the Data Type for Account Field in Survey_Target Object is changed from Lookup to Master-Detail.
Solution:
Be sure the end-user has FLS on the Question Order (Order_vod__c) field in the Survey_Question_vod__c object. Also, be sure the Data Type for Account Field in Survey_Target Object is Lookup.
Related Documentation:
CRM Help Documentation: Surveys Overview