Overview:
The Call Objectives Home Page widget includes a count of all objectives and objectives that pass an alert threshold. Tapping the widget opens a list view of the current Call Objectives. The user sees a different number of Call Objective alerts in the Call Objectives Home Page widget compared to the alerts in the list.
Call Objectives Home Page widget:
List of the current Call Objectives:
Root Cause:
The records are downloaded Offline but the user does not have access to those Accounts which are assigned to the missing Call Objectives.
The number of Call Objectives displayed depends on the following criteria:
- Not completed (Completed_Flag_vod__c = FALSE)
- Has an Account associated
- Does not include Call Objectives that are recurring if the user has Field Level Security (FLS) to Recurring_vod__c field
- Does not include Call Objectives that have a parent objective if the user has FLS to Parent_Objective_vod__c field
- Does not include Call Objectives past the threshold date defined in the Veeva Setting CALL_OBJECTIVES_ALERT_THRESHOLD_DAYS
Solution:
Grant access for the user to those Accounts which are associated with the missing Call Objectives.
Related Documentation:
CRM Help Documentation: Call Objectives