Overview:
When taking action on a Suggestion with the Call_Objective_vod record type, an end-user is receiving the error message: 1 Call Objective/s failed to create. User does not have permission to update or create records for object 'Call Objective'.
Root Cause:
The Suggestion record is misconfigured. Or, the end-user does not have the appropriate permissions to perform the action.
Solution:
Specify a Call Objective record type in the Call_Objective_Record_Type_vod__c field within the Suggestion record.
Additionally, ensure the user has the following permissions:
- Create object permissions on the Call Objective object.
- Field-Level Edit security to the Mobile_Id_vod__c field on the Call Objective object.
- Field-Level Edit security to the Call_Objective_Record_Type_vod__c field on the Suggestions object.
Related Documentation:
CRM Help Documentation:
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