Overview:
When clicking on the Survey link from an Approved Email, the user is redirected to a blank page with the following URL in the address bar:
http://%22%22/
Root Cause:
The Approved Email Survey is using Multichannel (MC) Engine Publishing. The problem occurs because the feature is not enabled in the affected org. An integration user is not configured in the Survey Administration page so that data can be written to the SFDC database.
Solution:
Follow the steps below to enable MC Engine Publishing:
- Set the Survey_Publish_Apex_vod Veeva Setting to 1.
- Provide an admin user access to the Survey Administration tab.
- Enter and validate the Integration User’s credentials in the Survey Administration page.
- Grant the Integration User edit permission to the Survey_vod, Survey_Target_vod, and the Survey_Question_vod objects.
- Clear the Veeva Cache.
Once MC Engine Publishing is configured, unlock and re-publish the Survey used with Approved Email.
NOTE: MC Engine Publishing only works when the Territories_vod field is used for the Territory assignment of the Survey.
Related Documentation:
CRM Help Documentation: