Overview:
When trying to edit and save an Account on CRM Platform Online, the end-user receives an error: Unknown Record Type Null. Please Check Your Permissions.
Root Cause:
Typically, the error occurs because the primary parent ID of the Account being updated is the ID of a deleted record. There is a data validation rule that validates the Primary Parent. Since there is no record at that ID, the check comes back as false and fails. This triggers the error.
Solution:
The user should do the following:
- Access the record in CRM or using Workbench.
- Edit or remove the primary parent value ID.
Related Documentation:
CRM Help Documentation: N/A
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