Overview:
Country Postal Code areas are not visible in the Veeva Align Territory Map View, even after the correct Postal Code is added in the Territory Geography record.
Root Cause:
The country__aln field is not populated on the Territory record or it is not a valid Postal Code for that country.
Solution:
In order to display the Postal Code on the Map, the Territory record must have a valid country__aln value (a valid Country should be set).
Related Documentation:
Align Help Documentation: Align Map Shapes